Forum » Last.fm Client Support

Won't scrobble: track is in directory set to not scrobble

 
    • tritrek a dit :...
    • Utilisateur
    • 8 jui. 2008, 7h36m

    Won't scrobble: track is in directory set to not scrobble

    What the heck?! Did anyone else get this message? I got this on "Ramones - Shena is a punkrocker"

    -=Tri-Trek=-
    • TheMannen a dit :...
    • Modérateur
    • 8 jui. 2008, 10h28m
    Well, have you made sure that the directory is set to scrobble? (Options -> Scrobbling)

    The most pointless war in history needs to be stopped. So join and stuff.
    • aspen4000 a dit :...
    • Utilisateur
    • 9 jui. 2008, 0h03m
    I had the same problem for a while. I have my music stored on an external firewire hard drive. However, in the scrobbling menu under preferences it would only show my computer's internal hard drive as the only option. I unchecked the hard drive, leaving nothing selected, saved, then exited both last fm client and itunes, then restarted both, and rechecked the hard drive box in the scrobbling menu. It suddenly started working.

    Hope that helps.

    • tritrek a dit :...
    • Utilisateur
    • 9 jui. 2008, 9h32m
    Yes, both things checked and now it works :) Thanks folks!

    -=Tri-Trek=-
    • scce a dit :...
    • Utilisateur
    • 6 août 2008, 11h53m

  • I had my D drive set to not scrobble cus thats where I used to keep my audiobooks =D so that was my problem... when I got this mesage.

  • I also have my music stored on an external hard drive, but it IS selected to scrobble, yet it seems as though only certain songs aren't scrobbling. Namely, most of Devendra Banhart's album, Cripple Crow. All songs are shown on the Last.fm album page.

    I tried the suggestions from aspen4000 to no avail.

    My external hard drive is rather large, however... Don't know if that would make a difference?

    Never had this problem before, that I noticed anyway.

    • Anjaaah a dit :...
    • Utilisateur
    • 14 mars 2009, 16h40m
    Having the same problem: 'track is in directory set not to scrobble.'

    But it is in the directory set to scrobble!

    I tried the above: uncheck my external drive etc. I even tried to uninstall last fm client, re-download, install again. Nothing works.

    Anybody???

    • Koobz a dit :...
    • Utilisateur
    • 14 mars 2009, 22h33m
    If you've updated to iTunes 8.1, you have to set C:\Program Files to scrobble. Setting all of C to scrobble will work as well, but you might have audio there you don't want scrobbling.

    I tried just setting the iTunes install directory to scrobble but that didn't work. I'm too lazy to try to find the specific folder that needs to be scrobbled since I don't have any music in Program Files, but it's somewhere in there.

    • [Utilisateur supprimé] a dit :...
    • Utilisateur
    • 14 mars 2009, 23h37m
    I've just updated to 8.1 and having the same problem - "directory not set to scrobble". It seems to be scrobbling AAC files but not MP3s. I've reset it to cover all of C; still doesn't work.

  • thank you koobz, my problem fixed now (=

    • Anjaaah a dit :...
    • Utilisateur
    • 15 mars 2009, 18h05m
    Works here too! (sorry for not mentioning the iTunes update, totally forgot about that). Thanks a lot Koobz!

    Pity though: Everything I played over the last two days is lost... I guess there's no solution to this one?

    • Eleima a dit :...
    • Utilisateur
    • 16 mars 2009, 8h43m
    I'm having the same problem as SkylsLaughing, unfortunately. I just updated to iTunes 8.1, tried setting every single file on my computer to scrobble (a bit of an overkill, true, but I'm starting to crack =), but to no avail. It's still not scrobbling any MP3s, and the scrobbler keep saying that the track is in a directory not set to scrobble.
    Help! Anyone find a workaround, please?

    • djspike a dit :...
    • Utilisateur
    • 17 mars 2009, 1h19m
    I just updated to iTunes 8.1 and noticed this problem.... here's what worked for me:

    1) in Last.FM go to the drive/folder where your music is stored and un-check it - then check it back and apply the settings.

    2) go to C > Program Files and set it to scrobble

    quirky... but it worked for me...

    • gSOLO a dit :...
    • Abonné
    • 17 mars 2009, 13h20m
    Checking C > Program Files did it for me. Thanks.

  • Confirmed

    Koobz 's fix works for iTunes 8.1 and Scrobber 1.5.2.38918

    • EZHart a dit :...
    • Utilisateur
    • 19 mars 2009, 20h35m

    Narrowed it down a bit . . .

    I tried just adding the iTunes folder and the Last.FM folder under c:\program files and that seems to work; no need to add everything under c:\program files.

    • [Utilisateur supprimé] a dit :...
    • Utilisateur
    • 20 mars 2009, 11h17m

    Re: Narrowed it down a bit . . .

    EZHart said:
    I tried just adding the iTunes folder and the Last.FM folder under c:\program files and that seems to work; no need to add everything under c:\program files.


    thanks. you can narrow it down even more. allowing scrobbling from the last.fm folder is enough. it's probably just a bug with the new itunes 8.1 and the last.fm plugin, so you have to enable scrobbling from the directory in which the last.fm client itself is installed. strange, but it works.

  • Cheers folks, I thought I was going mad as I've just shifted my library around. Glad I found this thread it seems to have fixed things for now.

  • This doesn't fix the problem.
    I am someone who has the reverse problem, everything scrobbles, including directories I have set NOT to scrobble, like podcasts. This needs to be addressed, not fixed in a quirky manner.

    Thanks for the information though, for most people this solution works for now (:

    • howisya a dit :...
    • Utilisateur
    • 20 mars 2009, 17h24m
    i used to be able to set Parent Folder to scrobble while Subfolder wouldn't scrobble, but now not only will that Subfolder scrobble, but also the (grand)parent folder of the Parent Folder will scrobble everything in its subfolders.

    • f1dz a dit :...
    • Utilisateur
    • 21 mars 2009, 18h53m

    Thx

    TheMannen said:
    Well, have you made sure that the directory is set to scrobble? (Options -> Scrobbling)


    Thanx dude... It's work...

    • cpando a dit :...
    • Utilisateur
    • 22 mars 2009, 9h51m

    WORKED!!!

    Thanks Koobz!
    I don't know what the hek did iTunes 8.1 did but it is true setting c:\program files directory as scrobbable fixed the issue.

    My scenario was:
    Music on an external drive with a fixed drive letter.
    Did't wanted to share all C: drive
    Worked fine till I installed the new itunes verdion
    Directory set as not scrobbable message appeared

    • Ruprect a dit :...
    • Utilisateur
    • 27 mars 2009, 13h43m

    Confirmed Fix

    I added my C:\Program Files to be scroobled, and now i can scrobble ahead.

    Using latest last.fm and iTunes 8.1.0.51

    • Mistah_TiM a dit :...
    • Utilisateur
    • 27 mars 2009, 14h05m

    Re: Narrowed it down a bit . . .

    EZHart said:
    I tried just adding the iTunes folder and the Last.FM folder under c:\program files and that seems to work; no need to add everything under c:\program files.

    I just added C:\Program Files\Last.fm ;)

    Любите музыку! // Love music!
Les utilisateurs anonymes ne peuvent pas poster de messages. Merci de vous connecter ou de créer un compte pour pouvoir intervenir dans les forums.